pub const IPV6 = struct 5393
5394
5395
5396
5397
5398
5399
5400
5401
5402
5403
5404
5405
5406
5407
5408
5409
5410
5411
5412
5413
5414
5415
5416
5417
5418
5419
5420
5421
5422
5423
5424
5425
5426
5427
5428
5429
5430
5431
5432
5433
5434
5435
5436
5437
5438
5439
5440
5441
5442
5443
5444
5445
5446
5447
5448
5449
5450
5451
5452
5453
5454
5455
5456
5457
5458
5459
5460
5461
5462
5463
5464
5465
5466
5467
5468
5469
5470
5471
5472
5473
5474
5475
5476
5477pub const IPV6 = struct {
pub const ADDRFORM = 1;
pub const @"2292PKTINFO" = 2;
pub const @"2292HOPOPTS" = 3;
pub const @"2292DSTOPTS" = 4;
pub const @"2292RTHDR" = 5;
pub const @"2292PKTOPTIONS" = 6;
pub const CHECKSUM = 7;
pub const @"2292HOPLIMIT" = 8;
pub const NEXTHOP = 9;
pub const AUTHHDR = 10;
pub const FLOWINFO = 11;
pub const UNICAST_HOPS = 16;
pub const MULTICAST_IF = 17;
pub const MULTICAST_HOPS = 18;
pub const MULTICAST_LOOP = 19;
pub const ADD_MEMBERSHIP = 20;
pub const DROP_MEMBERSHIP = 21;
pub const ROUTER_ALERT = 22;
pub const MTU_DISCOVER = 23;
pub const MTU = 24;
pub const RECVERR = 25;
pub const V6ONLY = 26;
pub const JOIN_ANYCAST = 27;
pub const LEAVE_ANYCAST = 28;
// IPV6.MTU_DISCOVER values
pub const PMTUDISC_DONT = 0;
pub const PMTUDISC_WANT = 1;
pub const PMTUDISC_DO = 2;
pub const PMTUDISC_PROBE = 3;
pub const PMTUDISC_INTERFACE = 4;
pub const PMTUDISC_OMIT = 5;
// Flowlabel
pub const FLOWLABEL_MGR = 32;
pub const FLOWINFO_SEND = 33;
pub const IPSEC_POLICY = 34;
pub const XFRM_POLICY = 35;
pub const HDRINCL = 36;
// Advanced API (RFC3542) (1)
pub const RECVPKTINFO = 49;
pub const PKTINFO = 50;
pub const RECVHOPLIMIT = 51;
pub const HOPLIMIT = 52;
pub const RECVHOPOPTS = 53;
pub const HOPOPTS = 54;
pub const RTHDRDSTOPTS = 55;
pub const RECVRTHDR = 56;
pub const RTHDR = 57;
pub const RECVDSTOPTS = 58;
pub const DSTOPTS = 59;
pub const RECVPATHMTU = 60;
pub const PATHMTU = 61;
pub const DONTFRAG = 62;
// Advanced API (RFC3542) (2)
pub const RECVTCLASS = 66;
pub const TCLASS = 67;
pub const AUTOFLOWLABEL = 70;
// RFC5014: Source address selection
pub const ADDR_PREFERENCES = 72;
pub const PREFER_SRC_TMP = 0x0001;
pub const PREFER_SRC_PUBLIC = 0x0002;
pub const PREFER_SRC_PUBTMP_DEFAULT = 0x0100;
pub const PREFER_SRC_COA = 0x0004;
pub const PREFER_SRC_HOME = 0x0400;
pub const PREFER_SRC_CGA = 0x0008;
pub const PREFER_SRC_NONCGA = 0x0800;
// RFC5082: Generalized Ttl Security Mechanism
pub const MINHOPCOUNT = 73;
pub const ORIGDSTADDR = 74;
pub const RECVORIGDSTADDR = IPV6.ORIGDSTADDR;
pub const TRANSPARENT = 75;
pub const UNICAST_IF = 76;
pub const RECVFRAGSIZE = 77;
pub const FREEBIND = 78;
}
IPv6 socket options